Email Outage Tuesday 10th May 2022 09:20:39


This morning we have identified an issue with our Exchange service. This is currently under investigation with our senior Team.

Issue has been resolved. Database rebuild has taken place.

Issue is still being worked on by our engineers. Issue currently affecting an estimated 50 users on the email network.